Platform Support Emergency Phone Lines are experiencing telephony issue for calls originating outside North America
Incident Report for ON24 Webinar Platform
Resolved
This issue has been resolved and new numbers are available in the Knowledge Center. Thank you for your patience!
Posted Apr 01, 2024 - 09:47 PDT
Investigating
When a call originating from outside North America attempts to call the On24 Platform Support Emergency line, an unexpected message is heard and the call is not connected.
This is being actively investigated as a Critical issue with our telephony providers.

Until this issue is resolved, please leverage the Chat and Ticket options to quickly reach support. We are very sorry for any inconvenience.
Posted Mar 20, 2024 - 09:41 PDT
This incident affected: Producer: Elite, Engagement Hub, Target, Forums, Go Live.