The ON24 team has implemented a complete solution and we are seeing full delivery and receipt for emails. While previous emails may be delayed all new emails are being sent and received as expected.
Posted Jun 23, 2025 - 05:40 PDT
Monitoring
The ON24 team has implemented a solution and we are seeing full delivery and receipt for emails, though some may be delayed. The team is monitoring for stability, however no further delay is expected on new emails.
Posted Jun 23, 2025 - 05:11 PDT
Identified
The issue impacting the timely delivery of some ON24 event emails has been identified and the ON24 team is working with its service partners to implement a resolution.
Posted Jun 23, 2025 - 03:12 PDT
Update
The issue impacting the timely delivery of some ON24 event emails has been identified and the ON24 team is working with its service partners to implement a resolution.
Posted Jun 23, 2025 - 03:11 PDT
Investigating
Some event emails sent via the ON24 platform may be experiencing delivery delays. The ON24 team is investigating the issue and working toward a resolution.
Posted Jun 23, 2025 - 02:26 PDT
This incident affected: Audience: ON24 Audience Pages for Elite, Engagement Hub, Target, Forums, Go Live and Producer: Elite, Engagement Hub, Target, Forums, Go Live.